Browse Source

multi: bump minimum golang version to 1.15

Bump the minimum golang version to 1.15 in the go.mod file. The go
version is also updated in the Dockerfile and travis.yml file. This is
required so that the correct `errors.Is` method is used.
pull/371/head
Elle Mouton 6 months ago
parent
commit
208e1acc57
3 changed files with 3 additions and 3 deletions
  1. +1
    -1
      .travis.yml
  2. +1
    -1
      Dockerfile
  3. +1
    -1
      go.mod

+ 1
- 1
.travis.yml View File

@ -13,7 +13,7 @@ git:
depth: false
go:
- "1.13.x"
- "1.15.x"
env:
global:

+ 1
- 1
Dockerfile View File

@ -1,4 +1,4 @@
FROM golang:1.13-alpine as builder
FROM golang:1.15-alpine as builder
# Copy in the local repository to build from.
COPY . /go/src/github.com/lightningnetwork/loop

+ 1
- 1
go.mod View File

@ -26,4 +26,4 @@ require (
gopkg.in/macaroon.v2 v2.1.0
)
go 1.13
go 1.15

Loading…
Cancel
Save